Joint PWP8 EXIF and DXO converted tif EXIF mystery

Please use this forum to post bug reports, feature requests, tips, etc. for beta versions of Picture Window Pro 8

Moderator: jsachs

Post Reply
davidh
Posts: 534
Joined: June 9th, 2009, 2:16 am

Joint PWP8 EXIF and DXO converted tif EXIF mystery

Post by davidh » December 5th, 2018, 11:42 am

DXO Optics Pro 9 converted tifs, run through some PWP8 geometry transformations (e.g.Crop, Level, Resize) and saved with Include EXIF metadata checked on, fail to display in ViewNX2 or CaptureNX.
The images display as general icons in ViewNX2 and an attempt to open them fails with the message Unsupported file type.

Some other geometry transformations, like Add border (with at least one nonzero value) and Crop marks display distored in ViewNX2 - see the attachment, but in Capture NX they display normally.

This does not happen with PWP7 outputs.
Attachments
ViewNX2.png
ViewNX2.png (67.06 KiB) Viewed 65 times

jsachs
Posts: 1522
Joined: January 22nd, 2009, 11:03 pm

Re: Joint PWP8 EXIF and DXO converted tif EXIF mystery

Post by jsachs » December 5th, 2018, 1:13 pm

Not sure if this is related, but PWP 7 was unable to output 16-bit images as PNG while PWP 8 does support this. It may be that the other applications don't support 16-bit PNG.

Sorry, did not read your post carefully enough.
Jonathan Sachs
Digital Light & Color

davidh
Posts: 534
Joined: June 9th, 2009, 2:16 am

Re: Joint PWP8 EXIF and DXO converted tif EXIF mystery

Post by davidh » December 6th, 2018, 5:16 am

Sorry for the ambiguous description.
Let me be more precise. The attached images are printscreens of tif images from ViewNX2 saved as PNGs for the attachment purposes.

I tried to find out more and have discovered that if an image is exported from DXO Optics Pro 9 without EXIF data (Remove EXIF data - ON), processed in PWP 8 using some of the geometry transformations mentioned before, it has no problem to display correctly in ViewNX.

I must emphasize that I bring this here not as a problem but only as a kind of peculiarity, probably on the side of DXO Optics EXIF data.

Some time ago I also found that images processed in PWP7 and opened in DXO Optics Pro 9 show in the DXO browser as empty squares with message "Loading error" - see the attachment. But after clicking in the empty space, they display normally in both the browser and the preview window.
In this case the transformations were not limited to the geometry.
I do not seem to encounter this problem with PWP8.

I only use DXO Optics as a raw converter (and I like it) so it is easy to ignore those "Loading error" messages for PWP7 transformed images if they happen to be in the same folder.
By the way, DXO Optics is unable to preview anything with a dimension under 260 px. It will say "This image cannot be processed since is is to small". However it shows it in the browser.
Attachments
DXO Optics 9 Loading Error.PNG
DXO Optics 9 Loading Error.PNG (5.08 KiB) Viewed 33 times

Post Reply